Compatibilité

Cette page liste de façon la plus complète possible les informations sur la compatibilité du plugin WooCommerce Mondial Relay.

Compatibilité avec WooCommerce

Le plugin est compatible avec tous les versions de WooCommerce >= 2.6.

Dépendances

Dépendance FonctionVersion
ParcelShop Picker Le widget officiel de Mondial Relay est inclus pour la sélection de point relais sur la page de commande.4.0
jQuery Le widget Parcelshop Picker inclus dans le plugin est un plugin jQuery.
jQuery n'est pas inclus dans le plugin. Vous devez donc l'inclure dans votre thème (version 1.6 minimum).
-
OpenStreetMap Le widget Parcelshop Picker inclus dans le plugin utilise par défaut OpenStreetMap pour afficher les points-relais sur une carte.-
Leaflet Le widget Parcelshop Picker inclus dans le plugin utilise la librairie Leaflet pour afficher la carte OpenStreetMap.-
Google Maps Le widget Parcelshop Picker inclus dans le plugin peut utiliser en option Google Maps pour afficher les points-relais sur une carte.-

SOAP

Le plugin WooCommerce Mondial Relay se connecter au webservice de Mondial Relay via la bibliothèque PHP Soap.

Précédemment, le plugin pouvait utiliser la librairie NuSoap. Cette librairie n'étant pas compatible si vous utilisez PHP 7.0 ou supérieur, elle a donc été retirée du plugin.

Thèmes

Le plugin est compatible avec la très grande majorité les thèmes Wordpress/WooCommerce.

Certains thèmes, à cause de conflits de style ou de scripts, pourront nécessiter une modification spécifique. Vous trouverez plus d'informations sur la page de style.

Plugins

La compatibilité avec un plugin externe ne peut pas être assurée à 100%, car celle-ci peut varier suite à une mise à jour d'un plugin.

Aucun support n'est assuré sur un plugin externe à WooCommerce.

Navigateurs

Le plugin WooCommerce Mondial Relay (plus précisement, le widget ParcelShop Picker inclus) est compatible avec les navigateurs récents.

PHP

Il est recommandé d'utiliser la version la plus récente de PHP sur son serveur. Nous vous recommandons au minimum d'utiliser la version 7.1.

Le plugin WooCommerce Mondial Relay est développé sur la dernière version de PHP (7.3). Il est testé à chaque release en utilisant le plugin PHP Compatibility Checker qui permet de tester le plugin WooCommerce Mondial Relay avec PHP 7.0, 7.1 et 7.2.

Résultats

PHP Etat
7.0 OK
7.1 OK
7.2 OK

Vous pouvez trouver une liste des versions PHP supportés par les principaux hébergeurs sur le site PHP Versions.

Si vous souhaitez plus d'informations sur les versions supportées de PHP, vous pouvez vous rendre sur la page officielle. Vous trouverez aussi la liste des versions PHP obsolètes.

Qualité de code

Le plugin est développé en suivant les standards de code du PHP-FIG.